Results 1 to 2 of 2

Thread: Need help fixing my Phone.

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Junior Member
    Join Date
    May 2021

    Need help fixing my Phone.

    I tried to install twrp on my phone(Samsung Galaxy A20s-(A207F/DS running andriod 10) following this tutorial: (

    I entered download mode and on odin it said flash was successful after i tried to reboot my phone i was stuck in bootloop of download mode

    Here's the image:

    Now i'm in a different screen where it says:Secure Check fail:recovery.img.Here's a link to the image:

    I am in somalia but i think the phone was made in thailand due to the thai script on startup whenever i reset my phone.I was told to fix this i would need to reflash the firmware.How do i select the correct region and which version should i download?
    Last edited by Redrover12; 25-05-2021 at 08:39.

  2. #2
    Join Date
    Jan 2012
    Hi Redrover,

    What is the reason that u want to install twrp?
    To fix this issue you should install a offical firmware package of your phone and use it like normal.

    Best regards,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts