Results 1 to 8 of 8

Thread: Samsung A20s not charging?

  1. #1
    Junior Member
    Join Date
    Oct 2014
    Posts
    8

    Samsung A20s not charging?

    I used the new phone for 3 days, and after that it just stopped charging the battery. I tried a new charger the same problem. I bought a new USB connector replaced but it still won't charge?

    Sent from my CUBOT_X18_Plus using Tapatalk

  2. #2
    Administrator
    Join Date
    Jul 2012
    Posts
    7,723
    Quote Originally Posted by sshare [ Login above or register to see download links. ]
    I used the new phone for 3 days, and after that it just stopped charging the battery. I tried a new charger the same problem. I bought a new USB connector replaced but it still won't charge?

    Sent from my CUBOT_X18_Plus using Tapatalk
    Hi there

    When a device is not working correctly, you should go back to the retailer or let it checked by a Samsung Service Point (than it can be repaired under warranty)

  3. #3
    Junior Member
    Join Date
    Oct 2014
    Posts
    8
    I have no guarantee

    Sent from my CUBOT_X18_Plus using Tapatalk

  4. #4
    Administrator
    Join Date
    Jul 2012
    Posts
    7,723
    Quote Originally Posted by sshare [ Login above or register to see download links. ]
    I have no guarantee

    Sent from my CUBOT_X18_Plus using Tapatalk
    How come you don't have warranty?

    Obviously there's something more wrong with your device, and needs to be checked by a Samsung Service Point.

  5. #5
    Junior Member
    Join Date
    Oct 2014
    Posts
    8
    I lost my warranty

    Sent from my SM-G965F using Tapatalk

  6. #6
    Administrator
    Join Date
    Jul 2012
    Posts
    7,723
    Quote Originally Posted by sshare [ Login above or register to see download links. ]
    I lost my warranty

    Sent from my SM-G965F using Tapatalk
    By repairing the device yourself?

    Then it'll cost you; we can't help you further, sorry...

  7. #7
    Junior Member
    Join Date
    Oct 2014
    Posts
    8
    does anyone know what the problem is?

    Sent from my SM-G965F using Tapatalk

  8. #8
    Junior Member
    Join Date
    Jul 2020
    Posts
    1
    some time we may get trouble
    [ Login above or register to see download links. ]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •