Results 1 to 2 of 2

Thread: an error has occurred while updating the device software

  1. #1
    Junior Member
    Join Date
    Jan 2018
    Posts
    1

    an error has occurred while updating the device software

    i was installing one ui android pie on my samsung s7 edge, and i decided to go to the stock galaxy firmware, when i did this on odin i got an error which read, "an error has occurred while updating the device software"(on my phone). after this i tried re-flashing the phone multiple times with samsung s7 edge stock firmware but always got this error, "Complete(Write) operation failed"(on odin).

    any help provided will be greatly appreciated

    NOTE:
    *i have used many of the same firmware from different sources
    *the firmware used to work before this issue
    *tried using a different pc with different os
    *ran odin in admin mode and used updated version and older versions
    *tried to re-partition when flashing and used nand erase
    *i forgot to enable developer options when flashing phone
    *go this error on phone: KERNEL REV. CHECK FAIL. DEVICE:5, BINARY:1

    i have been reading about this in other forums but couldn't get the solutions posted there to work


    error on oden

    <ID:0/003> Added!!
    <OSM> Enter CS for MD5..
    <OSM> Check MD5.. Do not unplug the cable..
    <OSM> Please wait..
    <OSM> Checking MD5 finished Sucessfully..
    <OSM> Leave CS..
    <ID:0/003> Odin engine v(ID:3.1401)..
    <ID:0/003> File analysis..
    <ID:0/003> Total Binary size: 3914 M
    <ID:0/003> SetupConnection..
    <ID:0/003> Initialzation..
    <ID:0/003> Get PIT for mapping..
    <ID:0/003> Firmware update start..
    <ID:0/003> NAND Write Start!!
    <ID:0/003> SingleDownload.
    <ID:0/003> boot.img
    <ID:0/003> FAIL!
    <ID:0/003>
    <ID:0/003> Complete(Write) operation failed.
    <OSM> All threads completed. (succeed 0 / failed 1)
    Attached Thumbnails Attached Thumbnails Capture.JPG  

  2. #2
    Administrator
    Join Date
    Jul 2012
    Posts
    7,428
    Hi there

    Are you trying to downgrade? What firmware are you flashing? Where did you get this? Do you have Custom ROM on your device or ROOT?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •