Results 1 to 5 of 5

Thread: Galaxy S7 Does not recognize the O2 sensor in S-Health

  1. #1
    Junior Member
    Join Date
    Jul 2019
    Posts
    3

    Question Galaxy S7 Does not recognize the O2 sensor in S-Health

    Replaced a deceased S7 with a new, fresh out of the box 930 FD.

    Powered up, updated software to the following:

    G930FXXXS6ESGE

    Updated all the Google stuff, etc...

    Samsung Health does not recognize the O2 sensor for stress / pulse oximetry, and reports that this device does not support it (???)

    ANY suggestions

  2. #2
    Administrator
    Join Date
    Jul 2012
    Posts
    7,469
    Quote Originally Posted by GeoNez [ Login above or register to see download links. ]
    Replaced a deceased S7 with a new, fresh out of the box 930 FD.

    Powered up, updated software to the following:

    G930FXXXS6ESGE

    Updated all the Google stuff, etc...

    Samsung Health does not recognize the O2 sensor for stress / pulse oximetry, and reports that this device does not support it (???)

    ANY suggestions
    Hi there

    Let your device checked by a Samsung Service Point

  3. #3
    Junior Member
    Join Date
    Jul 2019
    Posts
    3

    After an nour with Samsung support online .....

    Is it POSSIBLE that due to the physical configuration of the device and how the SIM / SD carrier is set up, that the DUAL SIM variant does not actually support the SpO2 function because the SIM / SD carrier takes up the same physical space that the O2 sensor module would otherwise occupy? Samsung's on-line support didn't tell me there was anything wrong with the hardware but they are admittedly limited in what they can do remotely.

  4. #4
    Member
    Join Date
    Mar 2018
    Posts
    34
    It is more likely that the SPO2 function is disabled for certain CSC codes, since technically it could be considered a "medical device." Anyone have a dual-Sim S7 where pulse oximetry still works? If so, what CSC is it set up for?

  5. #5
    Junior Member
    Join Date
    Jul 2019
    Posts
    3

    Seems to work......

    Before giving up, rooting the blasted thing, and installing a non-Samsung ROM on my S7, I made a last-ditch effort and flashed a different ROM onto it. The device is a 930FD, originally with a ROM from Singapore (I think). I flashed a ROM for a 930F (Poland - XEO) and everything seems to be working, at least so far. Recognizes both SIMS, and all of the apps I have tried thus far seem to work without incident.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •