Hi Everyone,

I was wondering if there was any way to get around the boot loader 2.0 1.0 issue with Odin, I've found the correct firmware for my device but the PDA numbers are different.

[ Login above or register to see download links. ]

I have T825YDXU2BRL2 but I want to downgrade it to T825YDXU2BRG3 which was released on an earlier build for this tablet.

Is there any way of getting 7.0 onto this device or am I dreaming?

Thanks in advance, I am getting burnt out on this.

Badger.