Results 1 to 9 of 9

Thread: 4G problem after Nougat update SM-T815

  1. #1
    Junior Member
    Join Date
    Oct 2011
    Posts
    6

    4G problem after Nougat update SM-T815

    I have updated S2 to 7.0 OTA, but after upgrade I lost 4G. Only 3G works if I choose it in settings. Did hard reset, changed APN settings. Nothing helped.
    So I asked for a new SIM card from carrier and it still didn't work. Now comes the weird part.
    I took my 4G card from phone and put it in S2. Everything worked. 4G kicked in immediately. Then I put S2 card in phone and also everything worked with 4g. I returned it back to S2, but it didn't work.

    Eventually I downgraded to 6.0.1 and 4G works.

    Since it is SEE FW does anybody use some other FW that is similar to SEE regarding localization and that 4G works when chosen? I want to try that as a last option.

  2. #2
    Senior Member
    Join Date
    Dec 2011
    Posts
    41,809
    To summarise:

    1. S2 on 6.1 firmware 4G - OK
    2. S2 on 7.0 firmware 4G - NO
    3. S2 on 7.0 firmware with phone sim 4G - OK
    Your S2 is working with its 4G sim on 6.1 but not on 7.0.
    The question is why?

    After much thought, I cannot see any reason why it should not work.
    I can only suggest that you ask your network check your S2 sim account and connection.

  3. #3
    Junior Member
    Join Date
    Oct 2011
    Posts
    6
    That's about it.
    I also used SIM for mobile net with different number, and also it doesn't work.

    I'm waiting for carrier tech support to contact me (48 hrs), and need to check again with Samsung in the morning.

    But, like I said is there a different FW that I can use to see if it is FW problem. I can try with UK or something like that to check, but I would also like to try something that is similar to this one.

  4. #4
    Senior Member
    Join Date
    Dec 2011
    Posts
    41,809
    The 7.0 firmware is working with your 4G phone sim - is that correct?

  5. #5
    Junior Member
    Join Date
    Oct 2011
    Posts
    6
    Yes. And S2 card works in a phone which is also Nougat.

  6. #6
    Senior Member
    Join Date
    Dec 2011
    Posts
    41,809
    OK, so it does appear to be the S2 nougat firmware.
    Perhaps an update will resolve the problem.

  7. #7
    Junior Member
    Join Date
    Oct 2011
    Posts
    6
    I hope so. Since S2 is almost two years now who knows if they will update it more.

    Oh... And I tried a few more FW, and it is the same.

  8. #8
    Junior Member
    Join Date
    Jul 2017
    Posts
    1
    solution for missing 4G/LTE in Nougat upadate [ Login above or register to see download links. ]

  9. #9
    Junior Member
    Join Date
    Mar 2018
    Posts
    1
    Hi, i have the exact same problem with my T819Y. Did you find a soluting other than downgrading?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •