Results 1 to 4 of 4

Thread: Touch does not work!

  1. #1
    Junior Member
    Join Date
    Jun 2016
    Posts
    2

    Unhappy Touch does not work!

    Hello,

    I have S3, It was working fine with Official Samsung firmware and I root it with TeamWin to Lollipop 6.0.1 with no problems. Just when I installed the TeamWin for non suitable version everything changed. At first time, the phone started normally but with no touch, I tried several times to install Official & Unofficial roms but still the problem is no touch is possible.

    Any Help please

  2. #2
    Senior Member
    Join Date
    Dec 2011
    Posts
    41,791
    Quote Originally Posted by amerjarrar [ Login above or register to see download links. ]
    Hello,

    I have S3, It was working fine with Official Samsung firmware and I root it with TeamWin to Lollipop 6.0.1 with no problems. Just when I installed the TeamWin for non suitable version everything changed. At first time, the phone started normally but with no touch, I tried several times to install Official & Unofficial roms but still the problem is no touch is possible.

    Any Help please
    Sorry.
    This forum gives support for members using stock firmware.
    If you are using a custom firmware you are better looking on those forums.

  3. #3
    Junior Member
    Join Date
    Jun 2016
    Posts
    2
    Hello,
    I have S3 with 4.1.2 with Official version really, and before it was installed 4.3 with same problem.
    Thank you.

  4. #4
    Senior Member
    Join Date
    Dec 2011
    Posts
    41,791
    Quote Originally Posted by amerjarrar [ Login above or register to see download links. ]
    Hello,
    I have S3 with 4.1.2 with Official version really, and before it was installed 4.3 with same problem.
    Thank you.
    Touch problems can be firmware or hardware.
    The I9300 is an old phone, and very likely to be coming to the end of its working life.

    If you have had 4.3 on your phone then you should not downgrade as you will lose network connection.
    Best thing I can suggest is that you install a repair firmware:
    Samsung I9300 Galaxy S3 Repair Firmwares:
    I9300XXUGMK6 / OXAGMK6 v4.3: [ Login above or register to see download links. ]

    I9300XXUGMK6 / OLBGML1 v4.3: [ Login above or register to see download links. ]

    ---------------------------------------------------


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •