Results 1 to 8 of 8

Thread: Help! ! My galaxy note 4 s-lte korean version (sm-n916s) can't connect to 3g & lte

  1. #1
    Junior Member
    Join Date
    Apr 2016
    Posts
    5

    Help! ! My galaxy note 4 s-lte korean version (sm-n916s) can't connect to 3g & lte

    I live here in Philippines and i got a Samsung Galaxy Note 4 S-LTE Korean version (SM-N916S) but i wonder why i can't connect to 3G or LTE, so what did i do was to toggle my airplane mode to on and off, to get a signal but its only on 2G, but when a time that the phone tries to connect on 3G or LTE it will display a No Service and then limited services, by the way I tried all kinds of sims available here in Philippines, Smart, Globe, Sun, TM and its has the same problem.

    Where do you think is the problem is it in the baseband that is not compatible here in Philippines? is it possible that i can replace the baseband only Or it is possible that can I convert this Korean version Note 4 S-LTE (SM-916S) to international version.

    For information, I recently upgraded my Note 4 to Marshmallow 6.0.1 hoping that it will solve the problem, but unfortunately nothing happens, it still the same problem.

    Im very thankful if Anyone have an idea how to fix this problem. It will be of great help to me.

  2. #2
    Senior Member
    Join Date
    Dec 2011
    Posts
    41,789
    You cannot change the modem frequency support, but you can choose the bes network for your phone.
    According to this site it is between Globe and Smart, with Smart giving 100% compatibility for 4G.

    See here for details:
    [ Login above or register to see download links. ]

  3. #3
    Junior Member
    Join Date
    Apr 2016
    Posts
    5
    Thank you for quick response sir, But I already tried smart sim, and the problem is still the same, do you think it is in the hardware problem?

  4. #4
    Junior Member
    Join Date
    Apr 2016
    Posts
    5
    I have been digging through net, and i found something like SKT code, here i can set the network to GSM ONLY to connect only to GSM and there it is the connection is stable, call and text is ok.

    But i tried to set my network to WCDMA ONLY OR LTE ONLY then this is when my phone goes to no service or limited service and i can't received any text or call.

    Any idea how to set this SKT Code here in Philippines, if there is any correct setting to be used here in Philippines,

    Thanks for those masters who can assist me in this matter.

  5. #5
    Senior Member
    Join Date
    Dec 2011
    Posts
    41,789
    The frequency check gives the answer to your problem
    The only 100% compatibility network frequency is with Globe on 2G/2.5G (calls and text only)
    And Smart on 2G/2.5G and LTE.

    You will not get a perfect service with either.
    For Smart you will need to have:
    1. A 4G/LTE activated data sim card.
    2. A 4G/LTE data package with Smart
    3. To be in a Smart 4G/LTE reception zone.
    4. To have the LTE option in your mobile networks > network mode.

    Without all of these you will only get a voice/text service.
    You will not get a reliable 3G connection.

  6. #6
    Junior Member
    Join Date
    Apr 2016
    Posts
    5
    any update on this trade?

  7. #7
    Junior Member
    Join Date
    May 2019
    Posts
    2
    Hi. I have this problem too. It's been a long time since you posted this, but may I know if you were able to solve it? Thanks.

  8. #8
    Junior Member
    Join Date
    May 2019
    Posts
    2
    Have you tried adjusting the settings in the hidden menu of your phone? Mine can be accessed by dialing 319712358. Each note 4 version has its unique password.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •