Hello ,
I'll have a galsaxy s4 with csc 19505oxxemk3 with firmware must i take for a kit kat 4.4.2?
i live in the netherlands abbo kpn

mvgr

hangbuikie