Results 1 to 7 of 7

Thread: Problem with PEAP / 802.1x WiFi after 4.3 upgrade

  1. #1
    Junior Member
    Join Date
    Jan 2014
    Posts
    3

    Angry Problem with PEAP / 802.1x WiFi after 4.3 upgrade

    Hi all,

    After upgrading my S3 in Late december I can no longer associate to my PEAP / 8021.x corporate WiFi. I have factory reset my phone and cleared the cache partition.

    I can associate with WPA2-AES / TKIP, Open, WEP etc although this takes 3 attempts on my home WiFi (the S3 obtains an ip says its connected and the disconnects immediately).

    I'm using PEAP, No Certificate (either CA or User) & DHCP on an 802.1x secures SSID.

    As far as I can determine the S3 passes 802.1x authentication, receives an IP address, but when the WiFi controller issues a run state, the S3 rejects it and starts this process all over again ad infinitum. This all leads me back to the Kernel supplicant issue reported back in 4.2 on other devices.

    This all worked beautifully pre-update and has been tested on an Android 4.0.4 and Galaxy S4 device with no issues.

    I have put a ticket in with Samsung and they say I should visit a repair centre, but I do not hold out much hope.

    I was wondering if anyone else had this issue?

    Very annoyed really that with one software update Samsung have taken a very very good handset and trashed it in so many ways ...

    Regards

    D.

  2. #2
    Senior Member
    Join Date
    Dec 2011
    Posts
    41,789
    This does seem to be related to security, and maybe because of the updated security in 4.3.

    Make sure your router is using the security option matched on the phone (WPA/WPA2 PSK)
    Check that it is not your antivirus that is rejecting the connection.

    If all fails, then setting a static rather than Dynamic (DHCP) Ip usually resolves the issue - but a bit of a pain!!

    BTW: If you can connect to an open wifi hotspot (which I think you will be able to) then it points to your router/antivirus settings.
    Last edited by greenman; 13-01-2014 at 17:43.

  3. #3
    Junior Member
    Join Date
    Jan 2014
    Posts
    3
    Hi Greenman, thanks for the pointers.

    I have tried previous to this post a 'static' DHCP which did not solve the issue. The wireless I am trying to use is a corporate network with Cisco AP's and some WiSM II's using [WPA + WPA2][Auth(802.1X)] which is backed off to Radius.

    I will try the Antivirus suggestion next, after the phone comes back from the repair shop.

    If this fails then I will look to Cisco and Samsung again for solutions [but will post back here].

    Bit of a potential issue really as we support eduroam (a global SSID for education) and a lot of users have the S3 with 4.3

    Once again, thanks for you advice.

    Regards

    D.

  4. #4
    Senior Member
    Join Date
    Dec 2011
    Posts
    41,789
    The bottom line is that if your S3 connects to your home or external wifi hotspot, then the problem is with your work router.
    Do you have admin access or is it another staff member.
    If another member, you need to discuss with them your problems to see if a solution can be found.

  5. #5
    Junior Member
    Join Date
    Jan 2014
    Posts
    3
    Hi all,

    I had a colleague test from his S3 on a different carrier and his worked on all PEAP networks, so I can rule out any network routing / AP issue.

    *Issue resolved*

    Turns out this was a software issue with Kaspersky Internet Security 11.2.3 which was not allowing the WiFi adapter to bind to IPV4 or IPV6.

    The workaround for this is to navigate in Kaspersky Internet Security to:-

    Settings>>Web Protection>> And UNCHECK Web Protection (which checks websites before they are opened and is enabled by default)

    I shall get onto Kaspersky and alert them of this issue, as I'm sure others will have this issue as well.

    Regards

    D.
    Last edited by dude931; 15-01-2014 at 09:43.

  6. #6
    Senior Member
    Join Date
    Dec 2011
    Posts
    41,789
    Post #2

  7. #7
    Junior Member
    Join Date
    Jan 2014
    Posts
    1
    Yes, after Days of Pain, this is the solution. Thank U

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •