Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: 4.3 flash with Australian firmware, any issues?

  1. #1
    Junior Member
    Join Date
    Dec 2013
    Posts
    7

    4.3 flash with Australian firmware, any issues?

    Hi, Just wanted some feedback from anyone if they had success ODIN flashing their unlocked Galaxy S4 I9505 to the recently released XSA 4.3 unbranded Australian firmware? I hear reports of knox issues. How has it been, LTE working? anything else?

    Cheers

  2. #2
    Junior Member
    Join Date
    Dec 2013
    Posts
    7
    Anyone????

  3. #3
    Junior Member
    Join Date
    Nov 2013
    Posts
    2
    Quote Originally Posted by xfaust [ Login above or register to see download links. ]
    Hi, Just wanted some feedback from anyone if they had success ODIN flashing their unlocked Galaxy S4 I9505 to the recently released XSA 4.3 unbranded Australian firmware? I hear reports of knox issues. How has it been, LTE working? anything else?

    Cheers
    I have an unlocked, vodafone branded galaxy s4. I flashed it the other day with odin and the xsa 4.3 firmware. So far everything seems fine. I'm getting a lot more battery power usage. seems a little faster and smoother. I havent played around with knox yet.

  4. #4
    Junior Member
    Join Date
    Dec 2013
    Posts
    7
    Quote Originally Posted by toodyblade [ Login above or register to see download links. ]
    I have an unlocked, vodafone branded galaxy s4. I flashed it the other day with odin and the xsa 4.3 firmware. So far everything seems fine. I'm getting a lot more battery power usage. seems a little faster and smoother. I havent played around with knox yet.

    Hey, thanks for the feedback!

    New to the world of android etc and keen to update for sure. Might give it a go, but was a little wary with some of the reported issues with flashing.

    Thanks again.

  5. #5
    Junior Member
    Join Date
    Dec 2013
    Posts
    2
    I have a Telstra (Aus) Branded S4. I have downloaded the latest XSA firmware as I wanted to update to 4.3 and remove the telstra bloatware.
    I have been reading contradicting links online, some suggesting that this will be fine other suggesting otherwise.

    I am not willing to use ODIN to update the firmware until I have a more solid information. Hence my interest in this thread created by xfaust.

    Has anyone updated from a branded 4.2.2 to the Official non branded XSA 4.3 firmware?

    Cheers
    Grimace

  6. #6
    Junior Member
    Join Date
    Nov 2013
    Posts
    2
    Quote Originally Posted by Grimace [ Login above or register to see download links. ]
    I have a Telstra (Aus) Branded S4. I have downloaded the latest XSA firmware as I wanted to update to 4.3 and remove the telstra bloatware.
    I have been reading contradicting links online, some suggesting that this will be fine other suggesting otherwise.

    I am not willing to use ODIN to update the firmware until I have a more solid information. Hence my interest in this thread created by xfaust.

    Has anyone updated from a branded 4.2.2 to the Official non branded XSA 4.3 firmware?

    Cheers
    Grimace
    Yep, read my previous post. I have a branded 4.2.2 vodafone S4. flashed the other day with XSA firmware. Vodafone bloatware all gone and all running great. I did clear cache and data and restored to factory after firmware upgrade. Now my phone comes up as a XSA unbranded. No more vodafone stuff.

  7. #7
    Junior Member
    Join Date
    Mar 2012
    Posts
    6
    i concur also. flashed this firmware. everything is fine. no issues to report. battery usage about the same as any other 4.3 firmware. all works fine

  8. #8
    Junior Member
    Join Date
    Mar 2012
    Posts
    1
    yes, i did. have an official telstra sgs4 running official telstra rom, finally flashed the XSA 4.3 yesterday and all works.

  9. #9
    Junior Member
    Join Date
    Dec 2013
    Posts
    7
    Thanks guys, this is sounding good. My phone is an import through kogan. I'm not sure how this will affect me, or if it will.

  10. #10
    Junior Member
    Join Date
    Dec 2013
    Posts
    2
    Thanks for all the replies, and thanks to xfaust for posting this initially.

    EDIT: Just want to update this thread to say I have followed the advice of a ODIN firmware step by step guide.

    My phone was an unlocked But branded (telstra) handset.
    It is now flashed with the official XSA unbranded 4.3.

    Seems to be working as per normal.

    Thanks again
    Last edited by Grimace; 17-12-2013 at 03:01.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •