Results 1 to 3 of 3

Thread: Galaxy Y stuck at Samsung Logo after flashing custom ROM

  1. #1
    Junior Member
    Join Date
    Sep 2013

    Unhappy Galaxy Y stuck at Samsung Logo after flashing custom ROM

    Hi. I just tried flashing Chobitsdigitalis on my SGY and now it's stuck at the Samsung boot logo.

    Here's what I did on my phone:
    1. I rooted the phone using "".

    2. I used to do the following:

    a) Select "wipe data/factory reset" proceed to "YES"
    b) Select "cache partition"
    c) Select "apply update from sdcard"
    d) Select ""

    3. After flashing, I rebooted the phone and waited for 4 hours and nothing happened. It's stuck at the Samsung boot logo. I couldn't turn the phone off from the power button so I removed the battery. I couldn't boot to stock recovery.

    I've been reading from the guides and tutorials in forums in search of a way to fix the problem. I've found some solutions but I'm afraid to further damage the phone so I'd like to ask a couple of questions first.

    1. Suppose I missed "step b" (cache partition) from above, could that be the cause of my phone getting bricked?
    2. I've read that I need Odin Communicator to revive the phone and, I would also need an Odin Flash-able firmware. How can I be sure that I'm using the correct firmware for my phone? I get the idea that it depends on which country I'm from, but would it also depend on which mobile network I'm with? My phone is locked to Globe, a mobile network from in the Philippines.
    3. Before I flashed, I created a backup using CWM. Can I still use that to revive the phone?
    4. I tried using Kies to revive my phone through Firmware Update and Initialization. I was able to follow the steps but Kies could not detect my phone in 'Download mode' so I couldn't start the process. Is there anything else I need to do to connect my phone to Kies?

    These are my questions for now. I hope to hear from you guys as soon as possible. I'm just excited to see if I could do this by myself, but with your guidance of course.

  2. #2
    Junior Member
    Join Date
    Jan 2014
    before flashing costum mode, did you flash stock Rom?

  3. #3
    Premium Member
    Join Date
    May 2013
    go to recovery and clear cache then data usually take 1-2 min to bot at first time

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts