SamMobile - Powered by vBulletin
Page 1 of 22 12311 ... LastLast
Results 1 to 10 of 212
  1. #1
    Junior Member
    Join Date
    Mar 2016
    Posts
    8

    Exclamation Please help! Samsung Note 4 stuck at ODIN flash read failure / mmc read fail

    Greetings,

    This is my first ever forum post, and any assistance would be greatly appreciated

    I have spent hours reading though forums, watching tutorials and I'm out of ideas of what to try next.

    This is what my screen currently states and does not go out of this screen;

    ODIN MODE (HIGH SPEED)
    PRODUCT NAME: SM-N910F
    CURRENT BINARY: Custom
    SYSTEM STATUS: Official
    REACTIVATION LOCK: OFF
    KNOX WARRANTY VOID: 0x1 (4)
    QUALCOMM SECUREBOOT: ENABLE (CSB)
    AP SWREV: S1, T1, R1, A1, P1

    SECURE DOWNLOAD : ENABLE
    UDC START
    MMC: mmc_read fail
    ODIN : flash read failure

    <<The picture of the Android man>>

    Downloading...
    Do not turn off target!!


    I have tried the following;

    1 - I have installed Kies 3, going into to Tools and going though the firmware update; once downloaded, the phone stated "ODIN flash read failure" and refused to give a code to try out the recovery.

    2 - I have tried 5 different leads - I do not have the original cable, but surely at least one of these should be effective.

    3 - I have tried the USB leads both in the front and back of my computer (with Windows 10 as the OS).

    4 - I have the Samsung USB files installed.

    4 - ODIN

    I have downloaded and tried both Odin3 v3.10.7 and v3.10.6 and get the same responses in the Log.

    Firstly I have downloaded the latest recovery file I could find for my N910F titled;
    twrp-3.0.0-0-trltexx.img.tar

    When added to AP on the ODIN software, I get a green PASS! - with following at the end;
    <OSM> All threads completed. (succeed 1/ failed 0)

    Thereafter I have downloaded the latest firmware with the UK edition of the N910F file name;
    N910FXXS1CPC1_N910FBTU1COI1_N910FXXS1COK1_HOME.tar .md5

    When I add this to the AP button I get the following 2 sets of alternating dialogue;

    1

    <ID:0/004> Added!!
    <OSM> Enter CS for MD5..
    <OSM> Binary Check MD5.. Do not unplug the cable..
    <OSM> Please wait..
    <OSM> Checking MD5 finished Sucessfully..
    <OSM> Leave CS..
    <ID:0/004> Odin engine v(ID:3.1100)..
    <ID:0/004> File analysis..
    <ID:0/004> SetupConnection..
    <ID:0/004> Initialzation..
    <ID:0/004> Get PIT for mapping..
    <ID:0/004>
    <ID:0/004> There is no PIT partition.
    <OSM> All threads completed. (succeed 0 / failed 1)
    _____________________________________________

    2

    <OSM> Enter CS for MD5..
    <OSM> Binary Check MD5.. Do not unplug the cable..
    <OSM> Please wait..
    <OSM> Checking MD5 finished Sucessfully..
    <OSM> Leave CS..
    <ID:0/004> Added!!
    <ID:0/004> Odin engine v(ID:3.1100)..
    <ID:0/004> File analysis..
    <ID:0/004> SetupConnection..
    <ID:0/004> Complete(Write) operation failed.
    <OSM> All threads completed. (succeed 0 / failed 1)
    _____________________________________________

    Please note on the phone the line where it shows progress has the first notch highlighted, then it stops there.

    I've tried the same process several times with different cables, and positions on the computer, but to no avail. The only way I manage to turn off the phone is by taking the battery out and leave it for a while. I have also read by keeping the finger on the power button whilst the battery removed, this would effectively accelerate the removal of the power out of the system.

    Once I am to turn on again I press the vol- + Home + power on buttons at once, then the up arrow to go back into this screen.

    Sometimes the phone doesn't start up with this, and only turns on when plugging the phone with the USB cable to the computer, thereafter I get the following message;
    ------------------------------------------
    The same text at the top until it states "UDC START"

    Picture of a phone then .. the ! in a yellow triangle, then .. the a picture of a PC monitor

    "Firmware upgrade encountered an issue. Please select recovery mode in Kies & and try again."
    -----------------------------------------
    I have tried Kies 3 at this point before, but didn't work as stated above. I have uninstalled Kies 3 as I've read that it may clash with Odin3 software. Also I have tried again the Odin3 on this screen and I get the same 2 alterations as above.


    Apologies for the long message. It seems like some other people are also stuck at this stage too on other forums, and given the solutions tried out above; it seems that it solves most peoples problems, but a few are left still stuck.

    Are there any other options? Your assistance is greatly appreciated

  2. #2
    Senior Member greenman's Avatar
    Join Date
    Dec 2011
    Posts
    43,172
    Ok first of all it could be that your emmc (memory) is dead.

    But try this:
    1. Install SmartSwitch on your PC.
    Connect to SmartSwitch with phone in download mode.
    You will need your phone serial number and full model number.
    SmartSwitch does work on the N910F as I have one and have reinstalled my firmware.
    [ Login above or register to see download links. ]

    2.a) If that does not work then check that you are using an original quality USB cable.
    The thinner USB charging cables are no good as they cannot transmit data.
    b) With phone connected to your PC check in Windows Device Manager for any errors.

    3. Try flashing your firmware with a PIT file.
    N910F BTU PIT file here
    SM-N910F OXA multi CSC ( BTU CPW DBT ITV KOR XEF XEO )
    TRELTE_EUR_OPEN.pit
    [ Login above or register to see download links. ]

    Put PIT file into PIT in Odin
    Odin settings Re partition + F.Reset Time only.
    Press START.

    Reset Odin
    Put firmware .tar.md5 file in Odin (AP/PDA)
    Odin settings
    Auto Reboot + F.Reset Time only
    Press START.

    Wait until Odin has installed the firmware and your phone reboots into the initial start screen.

    [ Login above or register to see download links. ]

  3. #3
    Junior Member
    Join Date
    Mar 2016
    Posts
    8
    Hi Greenman,

    Many thanks for the very quick reply and depth of response; its greatly appreciated.

    I've have just been though (1) - installed SmartSwich on the PC, and it successfully installed the software for the first time the bar went all the way to the right without stopping as it did before, then stated "flash read failure"

    The phone automatically restarted afterwards onto the same screen, this time with two additional lines;

    Could not do normal boot.
    ddi : mmc_read failed
    ODIN MODE (HIGH SPEED)
    PRODUCT NAME: SM-N910F
    CURRENT BINARY: Custom
    SYSTEM STATUS: Official
    REACTIVATION LOCK: OFF
    KNOX WARRANTY VOID: 0x1 (4)
    QUALCOMM SECUREBOOT: ENABLE (CSB)
    AP SWREV: S1, T1, R1, A1, P1

    SECURE DOWNLOAD : ENABLE
    UDC START

    I'm not sure what the first two lines mean?

    Should I try step three with the PIT file, or should I do something else at this stage?

    Many thanks

  4. #4
    Senior Member greenman's Avatar
    Join Date
    Dec 2011
    Posts
    43,172
    Can you repeat the SmartSwitch install first?

    If same result then try with the PIT file.
    But it is looking like a dead emmc.

  5. #5
    Junior Member
    Join Date
    Mar 2016
    Posts
    8
    Hi again,

    I tried SmartSwich again, without resetting the phone and it had an error.

    I've just tried part (3), trying the PIT file, which was successful. then I tried again theN910FXXS1CPC1_N910FBTU1COI1_N910FXXS1COK1_HOME. tar.md5 file and I get the following again as before;

    <OSM> Enter CS for MD5..
    <OSM> Binary Check MD5.. Do not unplug the cable..
    <OSM> Please wait..
    <OSM> Checking MD5 finished Sucessfully..
    <OSM> Leave CS..
    <ID:0/006> Added!!
    <ID:0/006> Odin engine v(ID:3.1100)..
    <ID:0/006> File analysis..
    <ID:0/006> SetupConnection..
    <ID:0/006> Complete(Write) operation failed.
    <OSM> All threads completed. (succeed 0 / failed 1)

    Is there something that I'm doing wrong in Odin3? Both files twrp-3.0.0-0-trltexx.img.tar and the PIT file gave the green PASS, but the HOME.tar.md5 has yet to work. I downloaded the file from this website in Firmware section, and was only released the beginning of March.

    Quick note, what was interesting this time that the phone when restarted ( I'm leaving battery out for over 20mins) the Samsung Logo page very quickly flashed before starting the "Downloading... Do not turn off target" page, which is the first time. Am I getting somewhere with it?

    Many thanks again

  6. #6
    Senior Member greenman's Avatar
    Join Date
    Dec 2011
    Posts
    43,172
    Odin is downloading the firmware but it is failing to install (Write)
    Check:
    1. You are using an origianl USB cable in good condition, and not a thinner USB charging cable, as they cannot transmit the data.
    2. Connect directly to the PC USB posrt and not through a USB hub.
    3. Try another PC USB port.
    4. Try Odin version 3.0.9
    [ Login above or register to see download links. ]
    5. Make sure that SmartSwitch/Kies is not running when using Odin

    If you have checked all of these and they are OK then it looks like an emmc failure.
    If so, then a repair is the only solution.
    Last edited by greenman; 15-03-2016 at 20:48.

  7. #7
    Junior Member
    Join Date
    Mar 2016
    Posts
    8
    Thanks again for the quick reply.

    Oh, that's a shame. Is there any other way to find out for 100% that the emmc board is dead? Is it easy to find a repair for this in the UK? Is it something the phone shop can do, or do I need to purchase another mother board? (Sorry I'm not familiar with emmc).

    Many thanks

  8. #8
    Senior Member greenman's Avatar
    Join Date
    Dec 2011
    Posts
    43,172
    Quote Originally Posted by Noogy [ Login above or register to see download links. ]
    Thanks again for the quick reply.

    Oh, that's a shame. Is there any other way to find out for 100% that the emmc board is dead? Is it easy to find a repair for this in the UK? Is it something the phone shop can do, or do I need to purchase another mother board? (Sorry I'm not familiar with emmc).

    Many thanks
    I think all of your fruitless attempts have indicated the emmc is the problem.
    If you are reasonably competent the Note 4 is easy to work on and there are a number of YouTube teardown videos.
    One here chosen at random:
    [ Login above or register to see download links. ]

    Motherboards can be purchased.
    Try eBay or a site like this:
    [ Login above or register to see download links. ]

  9. #9
    Junior Member
    Join Date
    Mar 2016
    Posts
    8
    Good morning,

    I managed to get another quite new cable and placed in the main USB port on the computer. I've also downloaded Odin3.09 as recomended. I even un-installed SmartSwich to stop any potential interference. Miraculously it finally did install, with a green PASS in 04:56. And I get the following dialogue;

    ------------------------------------------------------------
    <ID:0/004> Added!!
    <OSM> Enter CS for MD5..
    <OSM> Check MD5.. Do not unplug the cable..
    <OSM> Please wait..
    <OSM> N910FXXS1CPC1_N910FBTU1COI1_N910FXXS1COK1_HOME.tar .md5 is valid.
    <OSM> Checking MD5 finished Sucessfully..
    <OSM> Leave CS..
    <ID:0/004> Odin v.3 engine (ID:4)..
    <ID:0/004> File analysis..
    <ID:0/004> SetupConnection..
    <ID:0/004> Initialzation..
    <ID:0/004> Get PIT for mapping..
    <ID:0/004> Firmware update start..
    <ID:0/004> SingleDownload.
    <ID:0/004> aboot.mbn
    <ID:0/004> NAND Write Start!!
    <ID:0/004> sbl1.mbn
    <ID:0/004> rpm.mbn
    <ID:0/004> tz.mbn
    <ID:0/004> sdi.mbn
    <ID:0/004> NON-HLOS.bin
    <ID:0/004> boot.img
    <ID:0/004> recovery.img
    <ID:0/004> system.img.ext4
    <ID:0/004> modem.bin
    <ID:0/004> cache.img.ext4
    <ID:0/004> hidden.img.ext4
    <ID:0/004> RQT_CLOSE !!
    <ID:0/004> RES OK !!
    <ID:0/004> Removed!!
    <ID:0/004> Remain Port .... 0
    <OSM> All threads completed. (succeed 1 / failed 0)
    ------------------------------------------------------------

    Once the phone rebooted, frustratingly the same message appeared again;

    Could not do normal boot.
    ddi : mmc_read failed
    ODIN MODE (HIGH SPEED)
    PRODUCT NAME: SM-N910F
    CURRENT BINARY: Custom
    SYSTEM STATUS: Official
    REACTIVATION LOCK: OFF
    KNOX WARRANTY VOID: 0x1 (4)
    QUALCOMM SECUREBOOT: ENABLE (CSB)
    AP SWREV: S1, T1, R1, A1, P1
    SECURE DOWNLOAD : ENABLE
    UDC START


    It seems like all the different tests and installations have been attempted, and as you've stated that would mean the emmc failure - therefore another mainboard required.

    I'm really appreciative of your time and advise; you are indeed a Super Moderator

    I hope other people who encounter the same issue do manage to get it sorted with one of the methods mentioned in this thread.

    Best wishes

  10. #10
    Senior Member greenman's Avatar
    Join Date
    Dec 2011
    Posts
    43,172
    Can you have a last attempt.
    Looking at this again, I'm wondering if your bootloader is damaged.
    Try using one of these repair firmwares.
    They have 4 files including a bootloader.
    ---------------------------------------------------------
    Samsung N910F Galaxy Note 4 LTE-A Repair Firmwares:

    N910FXXU1ANK4 / OXA1ANK4 v4.4.4: [ Login above or register to see download links. ]

    N910FXXU1BOC3 / VFG1BOC2 v5.0.1: [ Login above or register to see download links. ]

    -----------------------------------------------------------

Page 1 of 22 12311 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •