PDA

View Full Version : [General] EFS Partition problem



saidhabla
10-01-2015, 15:53
Hello.

I got my tablet stuck on the Samsung logo. When trying to fix it, seems that I've corrupted my EFS partition.

I get the next message when entering to stock recovery mode:

E:failed to mount /efs (Invalid argument)

I have tried many things, from going back to 4.1.2, install the new 4.4.2 with ODIN and ran some commands with ADB:

adb shell
mke2fs /dev/block/mmcblk0p3
mount -w -t ext4 /dev/block/mmcblk0p3 (also mount -w -t ext4 /dev/block/mmcblk0p3 / efs)
reboot

No errors but doesn't work, in some XDA forums they say I have to run this commands as SU but I can't do it, even if I run the zip to root the tablet. I also checked other options with Kies 2 and 3, but it says my device doesn't support initializing.

I went checking also to restore my EFS but it's 0Kb so is totally gone.

I'm in Mexico but bought mine at Costco and had no carrier... I'm wondering if I'm not able to fully restore it because I'm not downloading the right firmware.

Thanks.